compatibility - The Communicator.

Go to content

Main menu:

hidden

DEVICE COMPATIBILITY.

Supported (OS 5/6/7):


BlackBerry 7 devices:

  • BlackBerry Bold series (2011): BlackBerry Bold 9900/9930/9790

  • BlackBerry Porsche Design (2012): BlackBerry Porsche Design P'9981

  • BlackBerry Torch series (2011): BlackBerry Torch 9810

  • BlackBerry Torch series (2011): BlackBerry Torch 9850/9860

  • BlackBerry Curve series (2011): BlackBerry 9350/9360/9370/9380


BlackBerry 6 devices:

  • BlackBerry Torch series (2010): BlackBerry Torch 9800

  • BlackBerry Curve series (2010): BlackBerry Curve 9300/9330

  • BlackBerry Style 9670 (2010)

  • Blackberry Pearl series (2010): BlackBerry Pearl 3G 9100/9105

  • BlackBerry Bold series (2010–2011): BlackBerry Bold 9780/9788


BlackBerry 5 devices:

  • BlackBerry Bold series (2008–2010): BlackBerry Bold 9000/9700/9650

  • BlackBerry Tour series (2009): BlackBerry Tour (9630)

  • BlackBerry Storm series (2009): BlackBerry Storm 2 (9520/9550)

  • BlackBerry Storm series (2008): BlackBerry Storm (9500/9530)

  • BlackBerry Curve series (2009–2010): BlackBerry Curve 8900 (8900/8910/8980)

  • BlackBerry Curve series (2009): BlackBerry Curve 8520/8530.

Unsupported devices(OS 4/10)

  • BlackBerry Z series.

  • BlackBerry Q series.


Blackberry 4 and earlier devices:

  • BlackBerry 8800 series (2007): BlackBerry 8800/8820/8830

  • BlackBerry Pearl series (2006): BlackBerry Pearl 8100/8110/8120/8130

  • BlackBerry Pearl Flip series (2008): BlackBerry Pearl Flip 8220/8230

  • BlackBerry Curve series (2007): BlackBerry Curve 8300 (8300/8310/8320/8330/8350i)

  • Early pager models: 850, 857, 950, 957

  • Monochrome Java-based series: 5000, 6000

  • First colour series: 7200, 7500, 7700

  • First SureType phone series: 7100

iDevices (iPhone/ iPad/ iPod) compatible with:

  • iPhone 3GS

  • iPhone 4

  • iPhone 4S

  • iPhone 5

  • iPod touch (3rd, 4th & 5th generation)

  • iPad.

  • iPad mini.

Requires iOS 6.0 or later.
This app is optimized for iPhone 5

Android Devices:

Requires Android 4.0.3 and above.

 
Back to content | Back to main menu